Infiniti Q60 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter · #1 ·
I picked up my car today from the dealership where it got the radiant welcome lights installed. When I drove off the lot the steering was pulling hard to the right to the point I had to fight it to stay in lane. So, I turned around and promptly returned to dealer to check and fix. They seemed a little unsure what was going on but I shared my opinion it was likely the DAS system acting up. Apparently, there were problems with the 2014 Q50 and there is a method to re calibrate the DAS on the forums (involves turning off and on the car, rotating steering 90' to left and 90' right, etc..). Tech seemed to fix it using this method and didnt think it would happen again. He suspected it uncalibrated because he disconnected the battery for a long time as he worked on car. Hoping it doesnt recur. Anyone have this happen to them?

D

Ground lights are pretty cool and worth the $300.
 

·
Registered
Joined
·
430 Posts
Congrats brn_doc and have had no problems after three weeks of ownership.
 

·
Registered
Joined
·
175 Posts
Maybe just a one-off issue, but 2014 Q50 DAS problems are all well noted. But it seems that most of those issues were the vehicles in cold-weather areas. Other than the battery issue you mentioned, are you also located in a cold-weather area? Perhaps you all had a cold snap during the time your car was in for the upgrade?

Keep us posted, definitely hope there aren't any more systematic issues with this model, especially none like the 2014 Q cars.
 

·
Registered
Joined
·
85 Posts
Discussion Starter · #4 ·
Maybe just a one-off issue, but 2014 Q50 DAS problems are all well noted. But it seems that most of those issues were the vehicles in cold-weather areas. Other than the battery issue you mentioned, are you also located in a cold-weather area? Perhaps you all had a cold snap during the time your car was in for the upgrade?

Keep us posted, definitely hope there aren't any more systematic issues with this model, especially none like the 2014 Q cars.


Nope..no cold weather and it was kept inside the dealership garage the entire time. I think it was a one off issue. I have not heard of any more systematic issues with DAS in post 2014 vehicles... and the 2014's had all sorts of problems. Mine just lost calibration and was easily re calibrated with the recommended steps.
 

·
Registered
Joined
·
38 Posts
Mine has the same exact issue, I actually thought it was just me being picky again. I will try this solution later today.
 
1 - 6 of 6 Posts
Top