Infiniti Q60 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Hey guys,

So last night took my car to my family's house, when I came to a stop the check engine light came on and went into limp mode (car wouldn't go past 1500 RPM or past 5mph). When I pulled over smoke came from the engine and when I opened the hood I realized the coolant reservoir popped splashed everywhere. When I checked it this morning I also saw that the engine belt is loose and I was able to easily remove the belt.

Had to tow my car to dealership and they are going to let me know exactly what happened. But I also have custom cat-back exhaust on it and it doesn't make sense that the exhaust would cause the problem but how likely is it that they will blame it on the after market exhaust and not cover the damages?

Any thoughts or discussion is welcomed please let me know what you guys speculate!!

Thanks again
 

·
Super Moderator
Joined
·
2,121 Posts
It's the accessory belt. There were a number of Infiniti Q60s that were recalled because the accessory belt was not installed correctly at the factory. Check if your car was one of the affected ones.

There's no way the exhaust would have caused this issue. Could the belt or a pulley have come loose and hit the coolant tank cover?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #4 ·
It's the accessory belt. There were a number of Infiniti Q60s that were recalled because the accessory belt was not installed correctly at the factory. Check if your car was one of the affected ones.

There's no way the exhaust would have caused this issue. Could the belt or a pulley have come loose and hit the coolant tank cover?
Yes, its either it hit the coolant tank, or maybe caused the engine to over heat :confused:

But now after reading other posts I'm sure Infiniti has to cover it.

I'll keep you guys posted on what they tell me on Monday when they diagnose the problem.
 
1 - 4 of 4 Posts
Top