Infiniti Q60 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Threw an MIL the other day after about a week of having the car. Tried unscrewing and resecuring the gas cap, but it's still on. infiniti service tech told me to keep driving it for a week and the indicator should clear after a few drive cycles. If it doesn't take it back in. The CAP seems secure, but may be faulty. Definitely clicking at the end.

Anyone have any issues with an MIL early on?
 

·
Super Moderator
2017 Q60 Red Sport 400
Joined
·
3,698 Posts
MIL? Is that a check engine light?
 

·
Registered
Joined
·
66 Posts
Yes I think that is what he means.

I had the check engine light go off after I installed an aftermarket intake system. I ended switching back to stock but it never went away.

I ended up using Ecutek to reset the codes and it has stayed off now after 1500 miles.
 

·
Registered
Joined
·
148 Posts
Threw an MIL the other day after about a week of having the car. Tried unscrewing and resecuring the gas cap, but it's still on. infiniti service tech told me to keep driving it for a week and the indicator should clear after a few drive cycles. If it doesn't take it back in. The CAP seems secure, but may be faulty. Definitely clicking at the end.

Anyone have any issues with an MIL early on?
During first few thousand miles I found my past Q50 to be very sensitive to different gas stations, especially when not filled completely. It went away in few weeks. (Nothing of its kind with q60 yet)
 
1 - 4 of 4 Posts
Top