Infiniti Q60 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
I’m waiting on reviews for the newly released Aucar Mark 6 Tesla style screen. I’m hoping all the bugs from the previous two generations have been worked out. Otherwise from what I’ve been told the smart auto kits is the way to go.
 

·
Registered
Joined
·
24 Posts
I have the Smartautokit and love it. No complaints.
 

·
Registered
2017 Q60 Silver Sport
Joined
·
3 Posts
I have the GTA Auto kit and these are my issues. The included microphone sucks. I constantly switch over to the cars stock Bluetooth on my phone to talk. There’s a lot of lag on wireless Apple CarPlay like a good three seconds worth. (Press next song wait three seconds for it to change) The steering wheel controls are backwards, up which is normally next is previous, down which is normally previous is next. I contacted GTA for an update to fix the steering wheel controls they said there is no fix for it yet. (Months ago) I have tried to use wired Apple CarPlay but you either choose wireless or wired it will not switch back and forth. The good thing is that the Apple CarPlay does work. It connects to my phone automatically when I remote start the car. All the cameras work like reverse and 360 automatically. It was simple to install the box fits in the center consol easily with room to spare. The antenna to connect to your phone has a wide range I could be working in my garage with my phone on me and it still connects to the unit. I also contacted GTA for the password to go to the custom menu, they will not give you the password.

I have a QX70S I tried the unit from nifty city and it works so much better. You can go to the custom menu and change the settings and remap the buttons The antenna is much smaller The range is good only in the vehicle. not sure if it’s the vehicle but it uses the stock microphone built-in, no aftermarket microphone needed.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #6 ·
After much deliberation I decided to go with the Smart Auto Kits carplay integration unit for my 2018 Red Sport. The unit works fine for the most part but there are some minor quirks I'm hoping can be resolved by adjusting some settings.

Is there any way to stop the unit from reverting to the stock Navi/display when changing the audio from aux to AM/FM while under carplay? I always have to hold the back button to get carplay back on everytime I change inputs.

When answering a call the unit fumbles between bluetooth and whatever was playing from the radio for about a second or two until it gets back on bluetooth. Sometimes I have to unlock my iphone and change the speaker to bluetooth as it does not always automatically pick it up. Anyway to fix this glitch or is this normal operations I'll have to learn to live with?

Also just for reference I use Apple Carplay wired and my phone is paired through bluetooth to the car unit as I was told wireless carplay will not use the OEM microphone and speakers.

If these are indeed quirks I have to learn to live with can anyone with the Unavi carplay integration unit chime and in if they experience these issues as well?
 
1 - 6 of 6 Posts
Top