Infiniti Q60 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey guys I have a 2018 silver sport and after a few spirited runs with some friends my car won’t let me launch by using the brakes. When I hold down the brakes while attempting build boost the rpms won’t go above 1k, even if I’m flooring it. If I come off the brakes the car accelerates normally , maybe with a very slight delay. Has anyone ever experienced this ? I have AMS HX, LDP, CAI, infinti sports muffler and a JB4. This happened to me sometime last month and I thought it was heat soak so I bought the heat exchanger. I’m confused as to why this could be happening again.
 

·
Registered
Joined
·
16 Posts
Probably is heat soak. Idk where you live, but I have a similar set up to you. Im from Cali, and it's starting to get HOT outside. I was up in the canyons for a spirited drive, my oil temps got up to about 242 degrees and about 10 mins later my car started pulling timing. Pulled over and chilled for a bit, oil temps dropped, and the car was fine. So judging by what climate your from + how hard you beat on the car is probably the deciding factor.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Probably is heat soak. Idk where you live, but I have a similar set up to you. Im from Cali, and it's starting to get HOT outside. I was up in the canyons for a spirited drive, my oil temps got up to about 242 degrees and about 10 mins later my car started pulling timing. Pulled over and chilled for a bit, oil temps dropped, and the car was fine. So judging by what climate your from + how hard you beat on the car is probably the deciding factor.
Yeah I'm from New York, I didn't think it was hot enough outside for it to affect the car like that. After the car cooled off it was back to normal. I was surprised that the car would still suffer from heat soak with the AMS HE. Thanks for the information though!
 

·
Registered
Joined
·
984 Posts
I'm going to guess the repeated runs with the brake pressure applied at the onset tripped some trans temperature limit.
 
1 - 5 of 5 Posts
Top