Infiniti Q60 Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I live in NH and wondered how long it takes for the rear defroster to work? Wanted to clear the fog off the back window after rain and waited several minutes and got nothing? Is that normal?
 

·
Super Moderator
Joined
·
2,894 Posts
I live in NH and wondered how long it takes for the rear defroster to work? Wanted to clear the fog off the back window after rain and waited several minutes and got nothing? Is that normal?
Great question. I never have to use mine. You check your manual to be sure it was turned on?
 

·
Registered
Joined
·
63 Posts
Welcome! Like Bevo I don’t get much of an opportunity to use mine. I do remember it working well the few times I have though.
 

·
Registered
Joined
·
337 Posts
its not instant, when its humid out and rains my car fogs up but maybe after 10 minutes of rear defroster it all dissipates and then the rear defroster i think turns it self off after x amount of time to.
 

·
Super Moderator
Joined
·
2,894 Posts
If it's a matter of moisture built up inside the car then either the front defroster needs to be on or the A/C compressor needs to be turned on with the temp on warm for cold days to remove the moisture.

The A/C compressor is always ON anytime you use the windshield defroster no matter the temperature setting. That's how the moisture inside the car gets removed.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
its not instant, when its humid out and rains my car fogs up but maybe after 10 minutes of rear defroster it all dissipates and then the rear defroster i think turns it self off after x amount of time to.
Thanks for the reply. I have scheduled a service appointment. It is just not working :(.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
If it's a matter of moisture built up inside the car then either the front defroster needs to be on or the A/C compressor needs to be turned on with the temp on warm for cold days to remove the moisture.

The A/C compressor is always ON anytime you use the windshield defroster no matter the temperature setting. That's how the moisture inside the car gets removed.
It is the rear defroster that isn't working. The windshield and side view mirrors moisture clears fine. I have scheduled a service appointment to have it looked at. The rear defroster/defogger is not working at all :(.
 

·
Registered
Joined
·
130 Posts
Let us know what the problem was.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11
The defroster grid on my rear window was broken in several places so Infiniti is replacing the rear window with an OEM window since the vehicle is not even a year old. Sad that I am without my red sport for several days but they did give me a loaner vehicle.
 

·
Super Moderator
Joined
·
2,894 Posts
The defroster grid on my rear window was broken in several places so Infiniti is replacing the rear window with an OEM window since the vehicle is not even a year old. Sad that I am without my red sport for several days but they did give me a loaner vehicle.
Wonder how that happened? Was the rear glass tinted when you took delivery?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #13
We have no idea. Maybe someone cleaned the inside with something rough before I took delivery. The car had 6,000 miles on it when I bought it. It was the original window with no aftermarket tint. The window does have a slight tint like all the rear windows do.
 

·
Super Moderator
Joined
·
2,894 Posts
We have no idea. Maybe someone cleaned the inside with something rough before I took delivery. The car had 6,000 miles on it when I bought it. It was the original window with no aftermarket tint. The window does have a slight tint like all the rear windows do.
It may have had aftermarket tint that was removed before you took delivery and someone screwed it up.
 
1 - 14 of 14 Posts
Top