Infiniti Q60 Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 · (Edited)
Hi all. 2019 Redsport. 70 000km.

I've read a lot about turbo issues with this car.
Car's acceleration is terrible. It feels like there is zero boost.
No exhaust smoke. No loud noises from the engine bay except for when I hit 3k rpm (when the turbo kicks) there is a small 'squeak'. Consistently when I hit 3k.

I don't know if it's a cracked manifold or a leak in a line? Has anyone else experienced this? Thank you!
 

·
Super Moderator
2017 Q60 Red Sport AWD
Joined
·
1,898 Posts
Any DTCs?
 

·
Super Moderator
2017 Q60 Red Sport AWD
Joined
·
1,898 Posts
  • Like
Reactions: anthonyvalin

·
Super Moderator
2017 Q60 Red Sport AWD
Joined
·
1,898 Posts
From the 2016 Infiniti Service Manual:
Font Parallel Number Screenshot Rectangle
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #11 ·
Update:
Brought the car to Infiniti. They cleared the P0448 code with an ECM reprogram. They said it was running fine. I picked it up and lo and behold, still the same lack of power. Still feels like no boost. I tried to get the tech to drive another redsport and compare, but the of course, none on the lot.

I argued for a bit. Tech said they cant do anything without a code. Can't or won't???
I called a few other Infinitis in the area. One guy said to take a video and bring it in. A video wont show much. The car is still somewhat quick, but it's just not that "OOMPH" at 3krpm. No one will notice the lack of power other than a redsport owner.

There is a specialty Nissan shop nearby. My thought is to just pay them to diagnose, and hopefully its a hose or clamp...something small. Don't tell Infiniti anything.
But if they find something, it'll be an argument with Infiniti about warranty BS. Having another shop work on the car etc.

Any thoughts?
 

·
Registered
2021 Q60S AWD
Joined
·
170 Posts
Could it be heat soak? I remember when I felt heat soak it was super sluggish with no turbo, then I hit 3000 rpm and the car took off. Do u feel the lag during the first hard pull of the day? If yes, How hot is it outside ?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #14 ·
Could it be heat soak? I remember when I felt heat soak it was super sluggish with no turbo, then I hit 3000 rpm and the car took off. Do u feel the lag during the first hard pull of the day? If yes, How hot is it outside ?
Not heat soak. I have a the ams race heat exchanger. I did feel heat soak before the HE, but not anymore
 
1 - 16 of 16 Posts
Top