Infiniti Q60 Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
After much deliberation I decided to go with the Smart Auto Kits carplay integration unit for my 2018 Red Sport. The unit works fine for the most part but there are some minor quirks I'm hoping can be resolved by adjusting some settings.

Is there any way to stop the unit from reverting to the stock Navi/display when changing the audio from aux to AM/FM while under carplay? I always have to hold the back button to get carplay back on everytime I change inputs.

When answering a call the unit fumbles between bluetooth and whatever was playing from the radio for about a second or two until it gets back on bluetooth. Sometimes I have to unlock my iphone and change the speaker to bluetooth as it does not always automatically pick it up. Anyway to fix this glitch or is this normal operations I'll have to learn to live with?

Also just for reference I use Apple Carplay wired and my phone is paired through bluetooth to the car unit as I was told wireless carplay will not use the OEM microphone and speakers.

If these are indeed quirks I have to learn to live with can anyone with the Unavi carplay integration unit chime and in if they experience these issues as well?
 

·
Registered
Joined
·
96 Posts
Everytime I push any button like the home or climate buttons it flashes back to stock nav for a second. Ive learned to just live with it. If I change sound inputs, I have to hit the back button to get Carplay back.

Whenever I use the phone in the car I use the stock bluetooth phone. Everyone always complained about the call quality using the Smart Auto phone option. Didnt seem to make a difference if it was wired or wireless.

Over all the system works great otherwise. All touch, dial and wheel controls work as designed.
 
1 - 2 of 2 Posts
Top