Infiniti Q60 Forums banner
21 - 36 of 36 Posts

·
Registered
Joined
·
262 Posts
Discussion Starter · #21 ·
  • Like
Reactions: Bevo Horn

·
Registered
Joined
·
1,430 Posts
Well, we can predict where you will NOT be taking you Q for service in the future!
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #23 ·
Well, we can predict where you will NOT be taking you Q for service in the future!
Without a doubt! They've been bugging me to do a survey for the last few days. Did it after the new dealership told me there was oil in the downpipes. I dropped it off at the new dealer 4 days after the original dealer said "Everything's fine."
 
  • Like
Reactions: Bevo Horn

·
Registered
Joined
·
262 Posts
Discussion Starter · #24 ·
Got my car back today. New turbos and a new water pump. Much quieter on cold start and feels more powerful now too.
 

·
Registered
Joined
·
1,430 Posts
Got my car back today. New turbos and a new water pump. Much quieter on cold start and feels more powerful now too.
Just remember - don't go crazy with boost right off the get-go. The turbos are new, so they will need a break-in period, just like when the car was new. I'm assuming the dealership put a new oil & filter in, too?
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #26 ·
Yes, oil was changed as well. Have a belt squeal under moderate acceleration now though. Calling dealer in the morning.
 

·
Super Moderator
2017 Q60 Red Sport 400
Joined
·
3,722 Posts

·
Registered
Joined
·
262 Posts
Discussion Starter · #28 ·
24721
belt has no more than 15k miles on it.
 

·
Super Moderator
2017 Q60 Red Sport 400
Joined
·
3,722 Posts

·
Registered
Joined
·
262 Posts
Discussion Starter · #30 ·

·
Super Moderator
2017 Q60 Red Sport 400
Joined
·
3,722 Posts
Is that something that will go away over time then?
Not sure. The coolant could have made the belt harder and with less grip. The underside should have a velvety feel.
 

·
Registered
Joined
·
1,430 Posts
Is that something that will go away over time then?
Once the belt is contaminated, that's it. You'll be better off in the long run getting a new belt. The OEM serpentine belt P/N has been revised once.
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #33 ·
AC compressor realigned and belt replaced. May that be it for a while now...
 

·
Registered
Joined
·
3 Posts
Do you have a custom exhaust ? Mine just started blowing smoke when I have it in park after my recent oil change :/ I have lower downpipes and custom 2.5 exhaust with resonators no check engine light or anything the car runs good :(
 

·
Registered
Joined
·
262 Posts
Discussion Starter · #35 ·
Do you have a custom exhaust ? Mine just started blowing smoke when I have it in park after my recent oil change :/ I have lower downpipes and custom 2.5 exhaust with resonators no check engine light or anything the car runs good :(
At the time all I had was the Infiniti helmholtz resonators, everything else in the exhaust system was factory stock. I never had a check engine light for this either.
 

·
Registered
Joined
·
6 Posts

So, this is only the 2nd time in 6 months that I've seen the exhaust smoking like this. I drove the car for about 30 minutes, then it sat for an hour, before I remote started it before leaving again. This was after running for about 12 minutes. It smoked at about this level for a few blocks too once I started driving. I have not been able to get this to happen again. Going to the dealer on Friday though to get it documented and have them look at some things.

Wondering if adding an oil catch can would help since this is so intermittent?
Exactly the symptom I had. Just replaced both turbos under Powertrain warranty. Take to dealer! 🏎 I have a post with the details under turbo issues.
 
21 - 36 of 36 Posts
Top